#1 2015-09-02 02:37:08

einsteniano
Member
Registered: 2015-09-02
Posts: 3

[SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

Hello. I just installed locally the cms on my system running Ubuntu 14.04. After setting the database settings and other stuffs my attempt to open the admin panell results in the 404 error  http://localhost/ionize-1.0.7.1/admin  : "The requested URL was not found on this server". Some hint? Thanks..

Last edited by einsteniano (2015-09-02 02:38:34)

Offline

#2 2015-09-02 07:17:21

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

einsteniano@localhost:~$ sudo a2enmod rewrite

In /etc/apache2/apache2.conf look for the AllowOverride and set for the / and /var/www directory

AllowOverride All
einsteniano@localhost:~$ sudo apache2 restart

Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#3 2015-09-02 14:55:15

einsteniano
Member
Registered: 2015-09-02
Posts: 3

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

Already done. But the error still there.

Last edited by einsteniano (2015-09-02 14:55:51)

Offline

#4 2015-09-02 16:04:54

daniel
Member
Registered: 2014-02-28
Posts: 71

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

what does it say, if you go to

http://localhost/ionize-1.0.7.1/

without /admin?

And have you checked the .htaccess in your document root? On about line 119 should be this:

# OVH small plan :
# Replace the following line by :
# RewriteRule ^(.+)$ index.php?/$1
RewriteRule ^(.*)$ index.php/$1

You can try either

# RewriteRule ^(.+)$ index.php?/$1
RewriteRule ^(.*)$ index.php/$1

or

RewriteRule ^(.+)$ index.php?/$1
# RewriteRule ^(.*)$ index.php/$1

Offline

#5 2015-09-02 16:28:13

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

Do you have some logs?

/path/to/ionize/applications/logs/

or

/var/www/apache2/(error|access).log

Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#6 2015-09-02 19:07:50

einsteniano
Member
Registered: 2015-09-02
Posts: 3

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

Solved. I have reinstalled apache, changed a lot of permissione and modified the apache configuration. Please don't distribute a cms that require the customization of apache, because most shared hosting companies not allows this . The better solution MUST be allow per-user installation . joomla, wordpress & co does not require this preinstallation stuff. Please, update the installation README.md within the zip distribution and don't forget to mention apache2 and htaccess problem.The cms is beautiful.

Offline

#7 2015-09-03 11:10:23

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

@einsteniano: Most of the webservers are compatible with ionize, server requirements are:
http://doc.ionizecms.com/en/basic-infos … quirements

Apache2 server,
PHP 5.3,
MySQL 5.1

Apache2 must enabled the Rewrite engine (like other content management systems), the PHP should run in safe mode off, but the system working with safe mode on also. In your case maybe you used some customized version of apache2 or something. Can you share your server configuration and apache, mysql, php versions from before and after your changes?


Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#8 2015-09-25 21:23:58

ccmksy
Member
From: Hong Kong
Registered: 2013-11-30
Posts: 48

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

einsteniano wrote:

Solved. I have reinstalled apache, changed a lot of permissione and modified the apache configuration. Please don't distribute a cms that require the customization of apache, because most shared hosting companies not allows this . The better solution MUST be allow per-user installation . joomla, wordpress & co does not require this preinstallation stuff. Please, update the installation README.md within the zip distribution and don't forget to mention apache2 and htaccess problem.The cms is beautiful.

I also have the same problem. Now I can visit the admin page, but cannot login. I also under Ubuntu 14.04. But I discover that the ionize cms can run smoothly under Ubuntu12.04, No any error under ubuntu12.04, but a lot of error ubuntu 14.04.

So please tell me your server configuration and apache, mysql, php versions from before and after your changes?
Please! Please! Please!

Last edited by ccmksy (2015-09-25 21:25:24)

Offline

#9 2015-09-28 11:21:12

ccmksy
Member
From: Hong Kong
Registered: 2013-11-30
Posts: 48

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

einsteniano wrote:

Solved. I have reinstalled apache, changed a lot of permissione and modified the apache configuration. Please don't distribute a cms that require the customization of apache, because most shared hosting companies not allows this . The better solution MUST be allow per-user installation . joomla, wordpress & co does not require this preinstallation stuff. Please, update the installation README.md within the zip distribution and don't forget to mention apache2 and htaccess problem.The cms is beautiful.

I do agree einsteniano said : .....because most shared hosting companies not allows this....., So please fix this problem as soon as possible.

Offline

#10 2015-09-28 11:34:03

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

ccmksy wrote:

I do agree einsteniano said : .....because most shared hosting companies not allows this....., So please fix this problem as soon as possible.

I installed ~70-80 server and never needed customize Apache. Yes you must enable rewrite like EVERY CMS ON INTERNET. But enable rewrite is not costumizing Apache only configurating... I never founded a shared hosting company who not using rewrite engine, php safe mode is an other question, but the cms is working if that is enabled or not, Only a few background feature not working with safe mode on.

Because we don't know einsteniano what have done, we dont know what was the problem and we can not solve it.


Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#11 2015-10-18 14:26:51

ccmksy
Member
From: Hong Kong
Registered: 2013-11-30
Posts: 48

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

adamos42 wrote:
ccmksy wrote:

I do agree einsteniano said : .....because most shared hosting companies not allows this....., So please fix this problem as soon as possible.

I installed ~70-80 server and never needed customize Apache. Yes you must enable rewrite like EVERY CMS ON INTERNET. But enable rewrite is not costumizing Apache only configurating... I never founded a shared hosting company who not using rewrite engine, php safe mode is an other question, but the cms is working if that is enabled or not, Only a few background feature not working with safe mode on.

Because we don't know einsteniano what have done, we dont know what was the problem and we can not solve it.


Hello Moderator,

Now I solved the problem.
In past, I installed the cms in local hosting server firstly, then removed "install folder" and  uploaded it to share hosting.
But now, I change the procedure , I try to upload the whole folder (including install folder) to share hosting firstly, then install it. Finally, I can sign in the system. Now so happy !!

Offline

#12 2015-10-18 17:06:23

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

ccmksy wrote:

Now I solved the problem.
In past, I installed the cms in local hosting server firstly, then removed "install folder" and  uploaded it to share hosting.
But now, I change the procedure , I try to upload the whole folder (including install folder) to share hosting firstly, then install it. Finally, I can sign in the system. Now so happy !!

Hmm, the encoding output should be different in the procedure change and maybe the site path, in subfolder you must change the rewrite base in the .htaccess for proper working, the encoding I think depends with server in CodeIgniter. It may cause login issue (different password encoding what can be solve with password recovery), but not 404 error. 404 Error can create by disabling the rewrite engine or accessing a real 404 page or class-method.

Im glad you made it and sorry for not answering the first time:
If you installing on localhost and uploading the site, you should reset the users password if your localhost not same configuration than a real server (linux-windows). I do not run into this error because I using a up-to-date ubuntu for everything and my servers (and most of the shared hosting servers) are debian's or LTS ubuntu's.
If you uploading the site with database upload the install folder, execute and change the step to the admin user setting, the code will detect the uploaded database and encoding and you can update the admin user password there.


Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#13 2015-10-19 18:13:50

ccmksy
Member
From: Hong Kong
Registered: 2013-11-30
Posts: 48

Re: [SOLVED] Error 404 on page http://localhost/ionize-1.0.7.1/admin

OIC, by the way, Thanks for your support !!

Offline

What's Ionize ?

Ionize is an Open Source Content Management System created by webdesigners for webdesigners.

Created and maintained by Partikule and Toopixel, Ionize wants to be the easiest and most powerful CMS.

Can I help ?

Because talent is nothing without involvement, we are looking for motivated coders and webdesigners to join the project team.

Resources

Website : ionizecms.com
Documentation : doc.ionizecms.com

Development : Ionize on GitHub
Translations : Ionize Translations