#1 2015-12-08 19:23:34

redacfreelance
Member
Registered: 2015-12-08
Posts: 3

[SOLVED] Strange behaviour with index.php

Hi all,

http://www.redacfreelance.com/ is ok
http://www.redacfreelance.com/index.php is ok
http://www.redacfreelance.com/index.php/ is fail (in fact, only the home page can be opened, then clicking a link in the home page is error 404)

In development environment (WAMP), these 3 url are ok.

Then upload in production server (VPS Ubuntu) with exactly same files (config.php, .htaccess) and the result is above.

- AllowOverride is All everywhere
- mod_rewrite is ok

I spend all the afternoon to try to fix this issue but without success :(

Help please :)

Last edited by redacfreelance (2015-12-08 21:16:46)

Offline

#2 2015-12-08 21:02:32

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Strange behaviour with index.php

Why do you want use the index.php/ ?


Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#3 2015-12-08 21:16:11

redacfreelance
Member
Registered: 2015-12-08
Posts: 3

Re: [SOLVED] Strange behaviour with index.php

It was just to show that there was a misconfiguration somewhere.

Ok, finaly got it !

The solution : apt-get install libapache2-mod-php5

Now all internal links are ok : solved

Offline

#4 2015-12-08 23:07:49

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: [SOLVED] Strange behaviour with index.php

Oh, your php was too old?


Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#5 2015-12-09 07:53:04

redacfreelance
Member
Registered: 2015-12-08
Posts: 3

Re: [SOLVED] Strange behaviour with index.php

ionize seem to need mod_php instead of fast_cgi.

I recommend to verify this point during setup install verification

Offline

#6 2016-01-19 09:20:30

damascus
Member
From: Brisbane, Australia
Registered: 2013-04-08
Posts: 270
Website

Re: [SOLVED] Strange behaviour with index.php

@redacfreelance - i installed it on both mod_php and fast_cgi systems, though i may have needed to change extra config to get fast_cgi working fine though - years ago so cant recall, but maybe issue during install that never repeated once i played with some settings.

I do recall changing the .htaccess redirect line, something to do with an extra or missing "?"

I also maybe changed $config['uri_protocol']     from 'REQUEST_URI' to 'AUTO', but unsure if that was during testing or required change from base value.

But these feel like they are more specific to the server beyond just fast_cgi, and it definetly runs great with 'index.php' or not now.

Last edited by damascus (2016-01-19 09:23:41)


Webmaster | OneCNC Australia

Offline

What's Ionize ?

Ionize is an Open Source Content Management System created by webdesigners for webdesigners.

Created and maintained by Partikule and Toopixel, Ionize wants to be the easiest and most powerful CMS.

Can I help ?

Because talent is nothing without involvement, we are looking for motivated coders and webdesigners to join the project team.

Resources

Website : ionizecms.com
Documentation : doc.ionizecms.com

Development : Ionize on GitHub
Translations : Ionize Translations