#1 2015-04-23 08:01:34

abda11ah
Member
Registered: 2015-04-23
Posts: 4

Fresh install into subfolder = 404 errors

Hi,
I'm running Ubuntu x64 + apache 2.4.7 + a2enmod rewrite enabled.
I made a fresh install of the latest stable release into http://127.0.0.1/io/
Install was successful but all the website links returns 404 errors :

Not Found

The requested URL /io/my-account was not found on this server.

Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80

Offline

#2 2015-04-24 09:30:57

Kink
Ion Tester
From: France
Registered: 2010-06-04
Posts: 581

Re: Fresh install into subfolder = 404 errors

Perhaps, you need to edit your htaccess file with :

RewriteRule ^(.*)$ index.php?/$1 [L]

From documentation : http://doc.ionizecms.com/en/installatio … leshooting


Webmaster / OUF!WEB

Offline

#3 2015-04-27 08:17:38

abda11ah
Member
Registered: 2015-04-23
Posts: 4

Re: Fresh install into subfolder = 404 errors

toujours pareil il veut rien savoir, tous les liens renvoient :
The requested URL /my-account was not found on this server.
The requested URL /services was not found on this server.

etc.

mon .htaccess (sans les lignes commentées) :

--------------------------------------
RewriteEngine On

# The RewriteBase / instruction is commented. Remove the "#" to uncomment
# RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond $1 !^(index\.php|robots\.txt)
RewriteRule ^(.*)$ index.php?/$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond $1 !^(index.php|themes|install|files|modules|robots.txt)
--------------------------------------

J'ai essayé de dé-commenter RewriteBase / et de redémmarer apache mais toujours pareil

Offline

#4 2015-04-27 09:12:14

Kink
Ion Tester
From: France
Registered: 2010-06-04
Posts: 581

Re: Fresh install into subfolder = 404 errors

Can you read your log file ? (Or post here the content)

in

/application/config/config.php

search and edit this line :

$config['log_threshold'] = 4;

Make writable (chmod 777) :

/application/logs

Webmaster / OUF!WEB

Offline

#5 2015-04-30 11:01:22

abda11ah
Member
Registered: 2015-04-23
Posts: 4

Re: Fresh install into subfolder = 404 errors

Ionize ne peut pas créé de log dans application/logs/ puisque c'est plutôt une erreur Apache.

Dans /var/log/apache2/access.log j'ai :

127.0.0.1 - - [30/Apr/2015:10:46:19 +0200] "GET /io/services HTTP/1.1" 404 499 "http://127.0.0.1/io/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"

Offline

#6 2015-04-30 13:55:06

Kink
Ion Tester
From: France
Registered: 2010-06-04
Posts: 581

Re: Fresh install into subfolder = 404 errors

Perhaps misconfiguration of apache vhost ?


Webmaster / OUF!WEB

Offline

#7 2015-07-14 03:03:08

ccmksy
Member
From: Hong Kong
Registered: 2013-11-30
Posts: 48

Re: Fresh install into subfolder = 404 errors

I also get this problem, Can you professional staff solve this as soon as possible? Actually, this problem should not appear in installation phrase. If anyone face the installation problem , that will let them give up to install. You want to see this result ??? I think you don't , right ?, so please seriously solve this basic problem, thanks!!

Offline

#8 2015-08-12 12:28:59

Torsten
Member
From: Remscheid, Germany
Registered: 2015-08-12
Posts: 6

Re: Fresh install into subfolder = 404 errors

I installed it on my test platform in a subdirectory, like www.domain.com/ionize/, with sample data, and only the home page works, not the sub pages, like the other users here described before.

RewriteRule ^(.*)$ index.php?/$1 [L] does not help in my case.

And it cannot be a misconfiguration of the Apache, because other CMSs work fine. I looked into the config file and the .htacess, but I cannot guess what might be causing this malöfunction.


ON ERROR GOTO BED

Offline

#9 2015-08-12 22:28:45

Torsten
Member
From: Remscheid, Germany
Registered: 2015-08-12
Posts: 6

Re: Fresh install into subfolder = 404 errors

Now I’ve found out that everything works if ionize is installed in the root directory instead a subdirectory. So the question is: How must the config file and/or the .htaccess be edited to make the CMS work in a subdirectory?


ON ERROR GOTO BED

Offline

#10 2015-10-18 17:11:02

adaliszk
Ionize Friend
From: Germany
Registered: 2010-09-20
Posts: 397
Website

Re: Fresh install into subfolder = 404 errors

Change the RewriteBase in .htaccess file:

RewriteBase /subfolder/

Webdeveloper, Programmer, Application developer, Ionize friend
@adaliszk

Offline

#11 2016-02-20 21:19:37

dast
Member
Registered: 2012-04-16
Posts: 18

Re: Fresh install into subfolder = 404 errors

I get the same problem. Got through all posts related to this issue. It just doesn't work!

Initially I wanted to upgrade from 0.9.9 to 1.0.8 locally on a Mac 10.11.3 Apache/2.4.16 (Unix) PHP/5.6.17. Tried with MAMP but also running Apache and php on System Level. I can access the page but not the admin.

Later I made fresh install of ionize. Just as a test. I have the same problems. Can't access localhost/subfolder/admin. Always get the same message

Not Found
The requested URL /Administration was not found on this server.

All described changes to .htaccess don't bring the desired result.

Please help! I have no idea on how to persue. Thanks

Offline

What's Ionize ?

Ionize is an Open Source Content Management System created by webdesigners for webdesigners.

Created and maintained by Partikule and Toopixel, Ionize wants to be the easiest and most powerful CMS.

Can I help ?

Because talent is nothing without involvement, we are looking for motivated coders and webdesigners to join the project team.

Resources

Website : ionizecms.com
Documentation : doc.ionizecms.com

Development : Ionize on GitHub
Translations : Ionize Translations